Kein Internet mehr

Kunde ruft beim Admin an:
K: “Mein Chef hat gesagt, ich soll den Router resetten, aber seit dem haben wir kein Internet.”
A: “Was genau haben Sie denn gemacht?”
K: “An dem Router war ein Loch mit der Aufschrift ‘Reset’, da hab ich mit ner Büroklammer reingedrückt.”
** Stille **
A: “Ich glaub ich weiß warum Sie kein Internet mehr haben…”

Posted in Administration | Leave a comment

Drucker druckte wirklich nicht

Es ist zwar schon einige Zeit her, ich denke aber immer noch lachend daran zurück. Es war zu der Zeit, als die HP 6L aktuell waren.

Eines Morgens kommt dem Chef seine Frau mit einem riesen Din A3-Zettel angerannt, auf dem Zettel stand groß mit Edding geschrieben: “Drucker druckt nicht!”. Gutmütig, noch leicht verschlafen und nicht an einen großen Fehler glaubend, schaute ich mir die Sachlage genau an. Ich konnte es erst nicht glauben, aber die Diagnose war eindeutig! Ohne einen Handgriff zu rühren war der Fehler schon behoben, denn ich sagte nur “Du, vielleicht liegt das am akuten Papiermangel des Druckers…?” (wer den 6L noch kennt, weiß, dass das Papier hinten senkrecht im Drucker stand). Als Belohnung für die schnelle Fehlerbehebung bekam ich einen der hochrötesten Köpfe zu sehen, die ich jemals gesehen habe :-)

Posted in Administration | Leave a comment

EDV ohne Computer

Vor einigen Jahren, einer von unseren oberen Chefs kommt zu uns in die EDV um ein paar Dinge abzusprechen.
Nach einer Weile klingelt sein schnurloses Telefon (ein interner Anruf einer anderen Abteilung). Er geht ran, meldet sich, hört kurz zu und sagt dann:

Ich kann grad nicht! Ich hab grad keinen Computer – ich sitze in der EDV!!!

Alle EDVler sahen sich sprachlos an :-)

 

Posted in Administration | Leave a comment

Der liebe Postausgang

Anruf bei mir von einer Userin:

Dominic, ich habe hier ein ganz seltsames Problem mit meinen E-Mails. Kannst du mal vorbeikommen? Ist echt komisch…

Mit den schlimmsten Befürchtungen in Richtung Userarbeitsplatz gelaufen. Dort angekommen auf den Thunderbird geschaut und im ersten Moment nichts seltsames bemerkt. Doch die Userin erklärte:

Ich habe gerade mal ein wenig rumgeklickt und bemerkt, dass im Postausgang in der Spalte Absender immer meine E-Mail-Adresse eingetragen ist. Ich habe doch nicht alle E-Mails an mich geschickt?

Aufregen und erklären brachte nichts – sie glaubt heute noch an einen Fehler…

Posted in Support-Anfragen | Leave a comment

Maustreiber mit hoher Systemlast

Anruf bei uns. Eine verzweifelte Userin.

Ja, hallo, ich rufe an, weil mein Excel total langsam ist. Die Maus hakt, und es dauert lange, bis ich Text eingeben kann, manchmal kommt da gar nichts.

IT:

Aha, hmhm, interessant…müsste ich jetzt mal gucken.

Etwa ein Speicherleck? In Excel würds mich nicht wundern, ist ja von Microsoft, da ist das ja quasi normal, höhö. Also mal Tante Google anwerfen, und recherchieren. Ist der Fehler bekannt? Gibts Patches dagegen? Fehlanzeige. Selber reparieren is nicht, weil ich nicht wüsste, wie. Weitergooglen.

Nach 20 Minuten ein erneuter Anruf.

Ja, ich bins nochmal. Also das wird hier immer schlimmer. Jetzt hakt das ganze System. Outlook, Firefox, nichts geht mehr.

Der Rechner ist vor 2 Wochen frisch installiert worden, und eigentlich sollte der RAM noch okay sein. Naja, ich hole mal ein Ersatzgerät aus dem Regal und fange an, es fertig zu machen. Kann ja sein, irgendein Hardwarefehler oder so. Trotzdem nervige Arbeit. Irgendwann noch ein Anruf.

Ich habe den Rechner ein paar mal neugestartet, das brachte aber nichts. Deswegen frage ich mal, kann das auch an der Maus liegen?

Normalerweise nicht, wir haben hier ganz normale Logitech-USB-Mäuse, 2 Buttons, Scrollrad, nichts wildes.

Ja, ich frag ja nur, weil ich mir dachte, ob es helfen könnte, dass ich mal die Batterie wechseln könnte.

WTF? Es stellte sich heraus, dass besagte Userin von zu Hause eine Funkmaus mitgebracht hat, weil sie besser in der Hand liegt. So ein hochgezüchtetes Gamerteil. Und sie war sich nicht bewusst, dass die Maus anfängt zu haken, wenn der Akku leer wird.

Wir haben die Userin dann eigenhändig zum Real rübergeschickt, neue Akkus besorgen, und ziemlich geflucht.

Posted in Support-Anfragen | Leave a comment

“Bitte keine Emails mehr….”

Ein neuer Mailserver muss her, wenn ein Admin so etwas hört, läuft ihm oder ihr meist ein kalter Schauer über den Rücken. Neue IP-Adressen, Kontenmigration – auf alle Fälle jede Menge Support Bedarf. Und viele Mitarbeiter greifen heutzutage auch von zu Hause oder unterwegs auf ihre berufliche Korrespondenz zurück.

Ich schrieb nach der Umstellung eine interne Nachricht, wie die Mitarbeiter auch von ausserhalb auf ihre Nachrichten zugreifen können. Eine UserIn war sehr hartnäckig und schrieb auch von Ihrem privaten Account an die Support Adresse. Sie eröffnete die Kommunikation mit dem Support, damit das wir prüfen sollten ob ihr Passwort richtig ist. Sie bekam die Antwort, dass wir ihr persönliches und geheimes Passwort nicht kennen, aber wir können ihr Passwort zurück setzen. Daraufhin hat sie uns Ihr Passwort gesandt – Facepalm 0.

Aber, es kommt noch “besser”. Nachdem die UserIn nun endlich private und berufliche Nachrichten empfangen kann, erreicht uns folgender Satz via Email. Ich zitiere:

“Nun klappt es, aber wenn Sie mir noch helfen können, die Mails ab und zu nicht zu bekommen… ”

Nach einem ordentlichen Facepalm1 bekam die UserIn eine Nachricht doch bitte den Haken “Beim Start Abrufen” in den Einstellungen des Kontos heraus zu nehmen.

EOF ;)

Posted in Administration | Tagged | Leave a comment

Richtig sichere Passwörter

Einer unserer Kunden hat sich von einem bekannten deutschen Hersteller eine neue Software gekauft.
Dazu war es notwendig dem installierenden Techniker einen Zugang zum neu eingerichteten Terminalserver zu gewähren.

Der Techniker erhält hierfür ein zeitlich begrenztes X509-Zertifikat. Zusätzlich ist das
Zertifikat noch mit einem 8-stelligen Passwort geschützt. Das erhält der Techniker auf einem gesonderten Wege.

Alle notwendigen Parameter sind vorhanden, alles klar? OpenVPN, ok. ? Gut..

Nach einer Woche schaue ich in die Log-Files, ob sich der Kollege schon einmal an dem Projekt zu schaffen gemacht hat. Nichts!

14 Tage später werden unsere Kunden unruhig, der Übergabetermin rückt näher, nichts passiert.. Also Mail schreiben, was ist los? Keine Reaktion..
Wenige Tage später telefoniert der Geschäftsführer des Kunden den den Vorgesetzten des Technikers.

Dann platzt die Bombe..

“Ihre Systemadminstratoren sind ein Haufen paranoider Spinner, Sicherheit ist ja gut und schön, aber was zuviel ist, ist zuviel. Unter diesen Umständen kann mein Techniker seine Aufgabe nicht erfüllen.”

Ok, tief Luftholen und ein bischen durch die Nase atmen.., was war passiert?

Das nachträglich zugesandte Password wurde ignoriert oder ist verloren gegangen.
Die einzig vorhandene Datei war die cert.pem. Also muß dort das Passwort drinstehen.
Steht auch drin und zwar zwischen

“—–BEGIN CERTIFICATE—–” und “—–END CERTIFICATE—–“.

Dieses Passwort täglich abzutippen ist aber selbst für den geschicktesten Hacker eine Zumutung, außerdem nimmt der VPN-Client nach 128 Zeichen (ich habe es selbst nicht probiert) keine Zeichen mehr an.

Die Sache klärte sich dann nach ein paar Erläuterungen auf, auch das Passwort fand sich wieder an.

Posted in Administration | Leave a comment

USV im Funkenflug

Eines Tages hat es der EDV-Abteilung gereicht: die Stromqualität des lokalen Stromversorgers war so grottig, daß jedes Jahr hohe 4-stellige Verluste an lokalen USVs und an Servernetzteilen geschrieben wurden. Ein Transientenrekorder zeichnete auf. Soll: Sinus, Ist: Dreieck mit überlagerten Dolomiten.

Eine große, zentrale USV wurde angeschafft. In allen Häusern wurde eine parallele SV-Versorgung aufgebaut. Die Serverräume bekamen neue Unterverteilungen. Der Umzug der Stromversorgung im zentralen Serverraum stand bevor. Das war natürlich verbunden mit dem Herunterfahren und Wiederanfahren aller Systeme.

Termine vereinbart, Downtime verabredet, Abläufe geplant. Alles war gut vorbereitet. Der Anschluß der lokalen Stromkreise und der Racks an die neue Unterverteilung lag in der Obhut des Hauselektrikers. Die Aufgabe bestand darin, aus 380V-Drehstrom 3x 230V auszukoppeln.

Als alles termingerecht fertig war, kam der Zeitpunkt des Anschaltens. Erst die lokalen USVs, die sicherheitshalber noch einmal belassen wurden, dann die Peripherie, dann die Server usw. “Alles richtig verkabelt ?” – “Ja, kann losgehen!”. Der Elektriker schaltet die Sicherungen zu, die USVs bekommen zuerst Strom.

Brutzel — Knister — Knall. Sicherungen fallen, es riecht. Eine Sicherung fällt nicht. Dahinter eine IMV-Victron-USV, 3000 kVA. Der Lüfter dreht, und hinten fliegen die Funken heraus. Es sieht aus, wie ein startendes Raketentriebwerk. Schnell zur Unterverteilung, Sicherung wieder raus. Danach riecht es sehr intensiv im Serverraum.

Die Wiederinbetriebnahme fand dann ohne lokale USVs statt, deren es 4 Stück zerlegt hatte, und natürlich um Stunden verzögert.

Was war passiert ? Der gute Mann hatte für die Verdrahtung ein 5-adriges Kabel verwendet, 3x Phase (380V), 1x Null und 1x Erde. Zwischen den Phasen entnahm er die 230V. Das Problem war, daß das Kabel 2x schwarze Adern für die Phase hatte. Offensichtlich hatte er die falsche Phase erwischt. Und deswegen fuhr die USV mit 380V – aber nur kurz. Sie flog im Funkenflug davon. Ich muß zugeben, daß der Anblick einer funkensprühenden USV etwas Faszinierendes an sich hatte.

Der Hauselektriker entschuldigte sich damit, daß er das Kabel “noch aus Altbeständen im Lager gefunden habe, was billiger gewesen sei, als neues Kabel zu beschaffen.”

Die Bedeutung des Sinnspruchs “nicht wissen, was Phase ist” hatte für die EDV an diesem Tag eine wörtliche Bedeutung erfahren …

 

Posted in Infrastruktur | 1 Comment

Rückruf unter /dev/null

Betroffen war ich hier als Privatkundin eines großen ISP-Unternehmens aus dem Westerwald. Der DSL-Anschluss war gestört, keine Verbindung ins Internet, kein Telefon.

Immerhin, dank Mobiltelefon konnte ich ein Support-Ticket eröffnen. Es folgte eine Terminabsprache für den Rückruf der Technik-Abteilung: Frühestes Terminangebot von deren Seite am Freitag, also 2 (!) Tage später. Unglaublich aber wahr.

Also habe ich ungeduldig und seufzend gewartet. Und endlich ist er da, der Tag X an dem alles wieder gut wird, wie ich dachte und hoffte. Also sitze ich zum abgesprochenen Termin gespannt neben meinem Mobiltelefon, dessen Nummer ich für den Rückruf angegeben habe. Als nach einer halben Stunde immer noch nichts geschehen war, habe ich dann wieder da angerufen und musste mir sagen lassen, dass der Rückruf erfolgt und ich ja leider nicht ans Telefon gegangen sei..

Auf meine bestürzte Nachfrage stellte sich heraus, dass die tatsächlich nicht auf der angegebenen Mobilnummer sondern auf dem abgehängten Telefon angerufen haben!

Der nächste verfügbare Termin war dann Montags oder Dienstags.. Und schlussendlich ergab die Analyse der Technik-Abteilung dann, dass sie in der Angelegenheit nichts ausrichten konnten und die Telekom[1] hier ran musste. Der Teil ging dann sehr schnell. Nur 45 Minuten später war ich wieder online.

[1] Die vertraglichen Konditionen sahen vor, dass ich die Telekom erst beauftragen durfte, wenn der ISP den Fall geprüft und grünes Licht dafür gegeben hatte. Anderenfalls hätte man mir ggf. Kosten in Rechnung gestellt, falls das Problem nicht auf Seiten Telekom gelegen hätte..

Posted in Support-Anfragen | Leave a comment

Hitziger Serverraum

Geschichten habe ich viele, hier eine die gerade noch gut ausging.

Vor vielen Jahren forschte und administrierte ich an einem Max-Planck-Institut. Die Arbeitsgruppe brauchte viel Rechenleistung. Deswegen stand ein grosser Serverraum voll mit Numbercrunchern, einer Notstromversorgung und einer Klimaanlage die stark genug war einen Vulkan runter zu kühlen.
Eines Tages, ich war eigentlich schon auf dem Weg in die Mensa, fragte jemand nach einem speziellen Kabel. Mein Arbeitsethos siegte über den Hunger – deswegen ging ich in den Serverraum das Kabel holen. Als ich die Tür öffnete schlug mir eine unglaubliche Hitze entgegen. Die Server liefen noch, bei der bestehenden Hitze hätten sie das Dessert aber
sicher nicht mehr erlebt. Gut, dass ich die Sache mit dem Kabel vor dem Essen erledigen wollte. Die Klimaanlage lief zwar, blies aber nur warme Luft in den Raum. Ich entschied mich dazu die heisse Luft mit grossen Lüftern aus dem Raum zu blasen, was ganz gut funktionierte. Aber warum funktionierte die Klimaanlage nicht? Auf die Lösung kam ich durch eine Befragung des Institungselektrikers und etwas Logik. Es gab einen unbemerkten kurzen Stromausfall, der von der Notstromversorgung abgefangen wurde. Alle Server und auch die Klimaanlage bekamen ihren Strom aus den Akkus. Geladen wurden die Akkus aus einem anderen Energiestrang, der vom Ausfall nicht betroffen war. Wirklich alles wurde vom Notstrom versorgt. Nur nicht das Steuergerät der Klimaanlage – das hing ganz ohne Redundanzen am Stadtnetz. Und musste nach einer Unterbrechung der Versorgungsspannung von Hand (!) wieder eingeschaltet werden.

Die Server waren gerettet, die Klimaanlage lies sich wieder starten, der Elektriker hatte einen neuen Auftrag – und die Mensa hatte inzwischen geschlossen.

Posted in Infrastruktur | Leave a comment